`
txf2004
  • 浏览: 6855706 次
  • 性别: Icon_minigender_1
  • 来自: 上海
社区版块
存档分类
最新评论

[ACM_HDU_1052]Tian Ji -- The Horse Racing(贪心算法)

 
阅读更多

Tian Ji -- The Horse Racing

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9786 Accepted Submission(s): 2718

Description
Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"


Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.


Input
The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.


Output
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.


Sample Input
3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
0


Sample Output
200
0
0


Source
HDU1052


设田忌为a,国王为b,如果两队所有未比赛的马中:

一、如果a的最慢速度大于b的最慢,则直接a的最慢与b的最慢比赛,赢一场;
二、如果a的最慢速度小于b的最慢,则用a的最慢浪费b的最快,输一场;
三、如果a的最慢速度等于b的最慢,则:
1.如果a的最快速度大于b的最快,则直接a的最快与b的最快进行比赛,赢一场;
2.如果b的最快速度小于b的最快,则用a的最慢浪费b的最快,输一场;
3.如果a的最快速度等于b的最快,即a与b的最慢与最快分别相等,则:
a.如果a的最慢速度小于b的最快,则用a的最慢浪费b的最快,输一场;
b.如果a的最慢速度等于b的最快,即a的最慢、a的最快、b的最慢、b的最快相等,说明剩余未比赛的马速度全部相等,直接结束比赛。

思考为什么不考虑a的最慢大于b的最快的情况?因为a的最快必定大于等于a的最慢,若a的最慢大于b的最快,则a的最快必定也大于b的最快,已经在第二种情况中考虑过了。

#include<stdio.h>
#include<algorithm>
using namespace std;
int main(){
	int n, i, j;
	int a[1000];
	int b[1000];
	while(scanf("%d", &n) && n){
		for(i = 0; i < n; ++i){
			scanf("%d", &a[i]);
		}
		for(i = 0; i < n; ++i){
			scanf("%d", &b[i]);
		}
		sort(a, a + n);
		sort(b, b + n);
		int begin_a = 0, begin_b = 0, end_a = n - 1, end_b = n - 1, ans = 0;
		for(i = 0; i < n; ++i){
			if(a[begin_a] > b[begin_b]){
				++begin_a;
				++begin_b;
				++ans;
			}else if(a[begin_a] < b[begin_b]){
				++begin_a;
				--end_b;
				--ans;
			}else if(a[end_a] > b[end_b]){
				--end_a;
				--end_b;
				++ans;
			}else if(a[end_a] < b[end_b]){
				++begin_a;
				--end_b;
				--ans;
			}else if(a[begin_a] < b[end_b]){
				++begin_a;
				--end_b;
				--ans;
			}else{
				break;
			}
		}
		printf("%d\n", ans * 200);
	}
	return 0;
}


=======================签 名 档=======================
原文地址(我的博客):http://www.clanfei.com/2012/05/842.html
欢迎访问交流,至于我为什么要多弄一个博客,因为我热爱前端,热爱网页,我更希望有一个更加自由、真正属于我自己的小站,或许并不是那么有名气,但至少能够让我为了它而加倍努力。。
=======================签 名 档=======================




分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics